Jump to content
  • Sign Up
  • Language

S4TI stuck on config window loop


jude28

Recommended Posts

I have carefully followed the directions to download the S4TI on Macbook air High Sierra 10.13.1. And I cant get it to work. The program loads up and opens but the config window comes up asking me to save the setting or something, I hit save, it says it needs to restart so it does and then it goes right back to the same thing. If I close out of the config window and proceed to the program its empty and the few options it allows me to click on causes the program to crash and it asks if i would like to restart. I've uninstall and reinstall a few times now. I have the program in my apps folder. I installed the universal Mono framework recommended. The sims and mods folders have not been moved. What am I missing?? I also read something about a debug feature and I have no idea where to find that.

 

 

Screenshot 2017-11-09 19.41.03.png

Link to comment
Share on other sites

  • Team

@jude28 What is the name of your Save folder in Documents?

Since the Save folder is localized, the language must match the one used in the game so that it can access your contents.

 

The Debug tool is available somewhere on the taskbar, typically where you should find the Preferences menu. Sorry I don't have a Mac.

Link to comment
Share on other sites

  • Team
Il y a 1 heure, jude28 a dit :

Or do mean the whole sims game folder in Documents? Because that one is just called Electronic Arts.

Yes the one inside Electronic Arts. But I see it's called The Sims 4, so en_US should work!

 

Have you tried the version from this post: http://luniversims.com/forums/topic/5970-s4ti-public-beta-macos/?do=findComment&comment=105481

 

Il y a 1 heure, jude28 a dit :

I did find the Debug option but its greyed out. It's not clickable. 

It's weird, it should not be greyed out. :ermm:

Link to comment
Share on other sites

  • Team

@jude28

Try this:

  • Add a new folder named Sims 4 Tray Importer in Documents.
  • Create a file with the name Sims4.GameInfos.Settings.xml
    and paste the following text :
    <?xml version="1.0" encoding="utf-8" ?>
    <Sims4.GameInfos.Settings>
      <GameInstallation>
        <Name>The Sims 4</Name>
        <Locale>en_US</Locale>
        <DisplayName>The Sims™ 4</DisplayName>
        <InstallDir>/Applications/The Sims 4.app/</InstallDir>
        <Version>1.0.0.0</Version>
        <ExePath>[InstallDir]Contents/MacOS/The Sims 4</ExePath>
      </GameInstallation>
    </Sims4.GameInfos.Settings>

    or
    Download this file Sims4.GameInfos.Settings.zip and extract the content in Documents.

    Edit Locale and InstallDir as needed.

 

Make sure Locale match the language used in game. It's used to locate your save folder and for loading localized texts from the game.
InstallDir should point to the Sims 4 app folder.

Other fields are not really used, but changing them can render the file usable.

 

 

The workaround is to switch to Wine and to run the fully featured Windows version on top of it. Still I don't know if that solution works since I've not yet received any feedbacks. :ermm:

Link to comment
Share on other sites

1 hour ago, deevo said:

Create a file with the name Sims4.GameInfos.Settings.xml

By this do you mean a word doc? 

I made the folder and then attempted to make another folder inside it named "Sims4.GameInfos.Settings.xml"

But then I couldn't paste the text in it.

And then I attempted to make a word doc with the code pasted and name it "Sims4.GameInfos.Settings.xml"

But it insisted it use ".docx" instead.

 

Link to comment
Share on other sites

Didn't work :/

I re-downloaded the Mac beta version too just to start new.

This time however the "debug" option worked and a window with text came up.

I read in another thread it should say "true" three times down the line. But mine says "false" "false" and the last one is "true".

Did I download something incorrectly?

 

5a0d3a7a321cd_Screenshot2017-11-1601_06_50.png.0374e771b28866ebe512020d08763819.png

Link to comment
Share on other sites

  • Team

@jude28 As shown in the screenshot it appears that the InstallDir value is empty.

This will cause IsGameInstalled to return false and will prevent contents from loading since some game resources are needed for the next steps.

 

Btw, the save folder seems to work since it show that your Tray folder contains 2 files.

 

Since debug now works, try to set the path again and see if it works.

 

The settings file supports 3 locations:

- Documents/Sims 4 Tray Importer

- ~/Library/Application Support/Sims 4 Tray Importer

- App folder

The settings file is always saved to ~/Library/Application Support/Sims 4 Tray Importer (apply to the latest version only) even if loaded from Documents.

So open ~/Library/Application Support/Sims 4 Tray Importer then remove the settings file and try again to see if that make any changes.

Link to comment
Share on other sites

  • Team

@jude28 They must have hidden it, here's how to access it:

 

In the Finder, click the Go menu in the menu bar, then choose one of the following:

  • Press and hold the Option key, then choose Library.

or

  • Go to Folder: Type the folder’s pathname (for example, ~/Library/ or ~/Library/Application Support/Sims 4 Tray Importer/), then click Go.


Source: https://support.apple.com/kb/PH25294?viewlocale=en_US&locale=en_US

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy