Aller au contenu
Ce site utilise des cookies ! En apprendre plus

Ce site utilise des cookies !

Les cookies nous permettent de personnaliser le contenu et les annonces, d'offrir des fonctionnalités relatives aux médias sociaux et d'analyser notre trafic. Nous partageons également des informations sur l'utilisation de notre site avec nos partenaires de médias sociaux, de publicité et d'analyse, qui peuvent combiner celles-ci avec d'autres informations que vous leur avez fournies ou qu'ils ont collectées lors de votre utilisation de leurs services.

 

Pour en savoir plus sur la manière dont google utilise certaines données collectées cliquez sur le lien suivant : 

https://www.google.com/intl/fr/policies/privacy/partners/

 

Pour continuer d'utiliser ce site, vous devez accepter (en bas de la page) de nous permettre de stocker ces cookies sur votre ordinateur :) 

 

Vous trouverez ci dessous la liste des cookies et leur utilité :

Révélation

 

While some cookies will almost always be set by the Suite, there are some cookies that are set only in very specific circumstances.  If you have a need to identify all cookies the Suite may set, the following is a list of cookies and their intended purposes.

  • ips4_hasJS

This cookie is set by javascript and then later read to determine if javascript is supported in the user agent.

  • ips4_ipsTimezone

This cookie is set by javascript to detect the user's local time zone so that the software can adapt the displaying of times automatically.

  • ips4_IPSSessionFront

This is a session tracking cookie, used to track the user between page clicks.

  • ips4_member_id

This cookie would contain the user's member ID, used to "remember" the user in case their session ends between visits.

  • ips4_pass_hash

This cookie would contain a hash used to validate that the viewing user's member ID was not forged (it is not the actual password hash).

  • ips4_cms_filters (Pages only)

This cookie would track filters set by a user when filtering content in the Pages application.

  • ips4_ipsApprovalQueueSplash (Moderators only)

This cookie would track that a user has acknowledged the splash screen in the Moderator CP so that it is not shown again.

  • ips4_language (Guests only)

This cookie is used to track a language preference for a guest if the site has more than one language installed and the guest user chooses a specific language to use.

  • ips4_anon_login

This cookie is used to track a user's anonymous login preference if they choose this option during the login process.

  • ips4_theme (Guests only)

This cookie is used to track a theme preference for a guest if the site has more than one theme installed and the guest user chooses a specific theme to use.

  • ips4_ipbforumpass_XXX

When a forum has a specific password set, this cookie is set once a user logs in to that forum to validate that they have logged in on subsequent page loads.

  • ips4_thumbnailSize (Gallery only)

This cookie tracks what type of table layout to use in Gallery listings (list view, small thumbnails or large thumbnails)

Be aware that third party addons may set cookies as well, and that third party services integrated with the Suite (such as Google Analytics or Facebook Logins) may also set their own cookies.

 

 

 

deevo

S4TI - Public Beta (MacOS)

Messages recommandés

@deevo Well sorry to be the bearer of bad news, but this last test version crashes like the last 2. And on top of that when selecting a household in the library,the main window no longer shows any pictures when on the general tab.

 

Now for a little longer test info.

 

I went back to the "working version" Sims4TrayImporter_20170710 : This one lets me get through all households as long as I put the tab back on general before picking a new household (left on cc or files tab and it crashes)

 

Sims4TrayImporter_20170930 and last 2 "Test" builds, crash the second you try and pick a new household in the library, no matter what tab you have selected (once you pick the cc tab). i.e. I can go through all households, as long as I do not hit the cc tab for any of them. Once you pick the cc tab, the next household picked from the library will crash.

 

Side Note: I tried to do the windows version on a VM, but will not work due to the missing .dll's that the mac sims folder must not have, so I assume Wine would not work either.

Modifié par twmuse

Partager ce message


Lien à poster
Partager sur d’autres sites

So I think I'm done with that toolkit unless I rewrite everything! :(

 

il y a 40 minutes, twmuse a dit :

Sims4TrayImporter_20170930 and last 2 "Test" builds, crash the second you try and pick a new household in the library, no matter what tab you have selected (once you pick the cc tab). i.e. I can go through all households, as long as I do not hit the cc tab for any of them. Once you pick the cc tab, the next household picked from the library will crash.

I almost know what is causing the problem, but it appears to be a Mono issue, whenever a null reference it encountered it crashes while it shouldn't.

 

il y a 45 minutes, twmuse a dit :

Side Note: I tried to do the windows version on a VM, but will not work due to the missing .dll's that the mac sims folder must not have, so I assume Wine would not work either.

What is the missing .dll?
The Windows version require the full .Net Framework 4.5.2 or higher. It may require some little fixes to work on Wine, but it should be easier to troubleshoot.

Partager ce message


Lien à poster
Partager sur d’autres sites

Uploaded a quick fix for November update.

 

This version remains the same since the build is broken and I can not rebuild it without rewriting everything.

If it fails, you may have to wait version 2.0, meanwhile you can try Wine for Mac and S4TI for Windows.

Partager ce message


Lien à poster
Partager sur d’autres sites

Sorry but the last 2 updates crash out the second you try to change households in the library. Even when you go back to the general tab before switching households. this is the last version that still works as long as you go back to general tab before changing households in the library.

 

Screen Shot 2017-11-08 at 4.00.52 PM.png

 

And sadly the last 2 updates to the windows version no longer start using virtualbox, the beta I got from you still works fine though.

Modifié par twmuse

Partager ce message


Lien à poster
Partager sur d’autres sites

@twmuse Sorry I can not patch this one, too much changes. :(

 

You'll have to wait for version 2.0 or try to run S4TI through Wine which allows Windows applications to run on Mac.

WineSkin, WineBottler or Play On Mac are modified versions of WineHQ designed to run better on Mac.

Partager ce message


Lien à poster
Partager sur d’autres sites
On 11/8/2017 at 5:54 PM, deevo said:

You'll have to wait for version 2.0 or try to run S4TI through Wine which allows Windows applications to run on Mac.

WineSkin, WineBottler or Play On Mac are modified versions of WineHQ designed to run better on Mac.

is there a tutorial on how to run the windows version through wine(bottler, skin, etc.)? i can't seem to figure it out because i need microsoft.net to be able to run the windows version, but i can't have it and s4ti setup running simultaneously in winebottler :'0 i'm not very experienced with wine and it's cousin programs, so i'm sorry if this is a silly question!!

Partager ce message


Lien à poster
Partager sur d’autres sites

@kuliritton Currently I don't think so. :ermm:

 

Wine is more common to Linux and Mac users, which I'm not.

 

Newer versions of Wine should simulate Windows 7 environment so you need to download Microsoft .Net Framework 4.5.2 or higher, the links are provided in both the release and beta page.

Some modified Wine comme pre installed with Mono which is not recommanded since WinForms is discontinued and unstable.

 

You should be able to find some tutorials on how to install .Net Framework on Wine.
Once installed you should not have any problems installing and running S4TI.

 

 

The Microsoft .NET 4.6.2 wrpr_v1.0 wrapper seems to come bundled with both WineSkin and .Net Framework preinstalled.

Citation

General Info:
This wrapper utilizes 3.7GB of disk space and is only compatible on Mac OSX 10.8 and above.

Wineskin wrapper utilizing WS9-64bitWineStaging2.2 with .Net 2.0 through to .Net4.6.2 plus the .Net verification tool. This wrapper should work with applications that require .Net 4.6.2 and lower. The full framework is not entirely implemented into Wine’s structure so expect some things to not work correctly.

Visual C++ 2005 to 2015, both x86 and x64 versions have been installed.

 

Installation:
Mount the .Net 4.6 disk image
Drag and drop the app to your preferred gaming folder
Install your app or game into the dot net wrapper
Configure the wrapper to your apps specifications
Enjoy!

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

I did download the newest update with the updated launcher but I'm still having the same issue. I also followed the steps online. I dont know what the problem is because it used to open before i updated it, but it would automatically close out when I clicked on a sim i created after the pets update. I updated mono but I dont know how to check if its working properly. Ugh. im so sad!:triste5:

Partager ce message


Lien à poster
Partager sur d’autres sites
On 12/26/2016 at 3:26 AM, deevo said:

Hi @deevo

 

Just wanted to say this latest version is working perfectly on mac with os High Sierra 10.13.3. No more crashing when switching Households when left on the CC tab. This one is a keeper. No more needing to use Windows on Virtual box or wine, so happy.Thank you for all your hard work.

Modifié par twmuse
  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

@twmuse Good to know! The only thing you will miss is the grouping and sorting. ^_^

By any chance how did you manage to update it without problems? Some still have problems updating the previous versions to the latest one.

Partager ce message


Lien à poster
Partager sur d’autres sites
1 hour ago, twmuse said:

Hi @deevo

 

Just wanted to say this latest version is working perfectly on mac with os High Sierra 10.13.3. No more crashing when switching Households when left on the CC tab. This one is a keeper. No more needing to use Windows on Virtual box or wine, so happy.Thank you for all your hard work.

Omg! Im so jealous! I would like to know how to get mine to work, help me please!!!5a80ed3ecece3_ScreenShot2018-02-11at8_22_54PM.png.cff42a24f3e2ddde25d79a69a5d1ccd8.png

Partager ce message


Lien à poster
Partager sur d’autres sites
1 hour ago, deevo said:

@twmuse Good to know! The only thing you will miss is the grouping and sorting. ^_^

By any chance how did you manage to update it without problems? Some still have problems updating the previous versions to the latest one.

@deevo Well, I just unzipped it (with macs built in system) dragged the old version to the trash (along with all its parts, I use AppCleaner to track all preferences and such down), emptied trash, dropped the new on in the applications folder (Still MUST BE in the applications folder) and fired it up.

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites
18 minutes ago, deevo said:

AppCleaner was probably the missing part. Thanks for the hint!

Yup, I have one too, it uninstalls the apps selected. Here's my proof...my feelings are sooooo hurt. What am i doing wrong? @twmuse are you using the most recent version of Mono?5a80ff4e992d7_ScreenShot2018-02-11at9_39_31PM.thumb.png.2ba3b1a1fa7b8cdf87c8157a76b4a5ca.png

Partager ce message


Lien à poster
Partager sur d’autres sites

@MsKittyKat Looks like CleanMyMac3 is missing one (why I changed a long time ago)

5a8104874624c_ScreenShot2018-02-11at6_57_54PM.jpg.27b60ee3e90fe22c1413ec7dd28a589a.jpg

 

Also I had nothing but trouble until I reinstalled the sims to the default location (applications folder) that origin puts it in.

 

I am running Mono 5.2.0

 

Sorry for the bad screen shot, it will only let me upload 20kb file...go figure.

Modifié par twmuse

Partager ce message


Lien à poster
Partager sur d’autres sites

Im going to try to update to 10.13.3. Then Ill download the updated version of s4ti. Then I'll give you an update.

 

Il y a 4 heures, twmuse a dit :

@MsKittyKat Looks like CleanMyMac3 is missing one (why I changed a long time ago)

5a8104874624c_ScreenShot2018-02-11at6_57_54PM.jpg.27b60ee3e90fe22c1413ec7dd28a589a.jpg

 

Also I had nothing but trouble until I reinstalled the sims to the default location (applications folder) that origin puts it in.

 

I am running Mono 5.2.0

 

Sorry for the bad screen shot, it will only let me upload 20kb file...go figure.

@twmuseLol, its ok. So which cleaner would you suggest? Is it the third file that also needs to be deleted? Where do I find that file? My Sims 4 is already located in my Applications folder as well. 

Partager ce message


Lien à poster
Partager sur d’autres sites

5a811dca0a422_ScreenShot2018-02-11at11_49_34PM.png.51e741f217aea52406c1e0c5fd6d7035.png

Il y a 3 heures, deevo a dit :

@MsKittyKat

Try AppCleaner as suggested by twmuse.

Mono 5.2.0 can be found here: https://download.mono-project.com/archive/5.2.0/macos-10-universal/.

@deevo

Ok, I'll try it...fingers crossed. Im currently updated to the 10.13.3. Im assuming its Version 1 thats currently opening @deevo

 

@deevo

Oh my goodness it still didnt work!:triste5: How do I know if I deleted the previous mono properly. I thought I ran the right command but I dont know. 

 

5a812fdc54a16_ScreenShot2018-02-12at1_05_09AM.png.06ac634530e482148cf63f368914e4bd.png

Sorry, this is what you meant by "about"...lol. Anywho, this is the version that actually opens, but crashes on the households created after the pets update.

@deevo

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, MsKittyKat a dit :

Sorry, this is what you meant by "about"...lol. Anywho, this is the version that actually opens, but crashes on the households created after the pets update.

Yep, that button! :/
A two years old version, I still have it archived but will require too much work to patch with all the changes. :o

 

Il y a 3 heures, MsKittyKat a dit :

Im assuming its Version 1 thats currently opening

Version 1 of what? :ermm:

 

For Mono, I think that one should work better: MonoFramework-MDK-5.2.0.macos10.xamarin.universal.pkg (last one)

 

Il y a 4 heures, MsKittyKat a dit :

How do I know if I deleted the previous mono properly. I thought I ran the right command but I dont know. 

Look for /Library/Frameworks/Mono.framework and /etc/paths.d/mono-commands.

 

Uninstalling Mono on Mac OS X

Run this script in a terminal:

sudo rm -rf /Library/Frameworks/Mono.framework
sudo pkgutil --forget com.xamarin.mono-MDK.pkg
sudo rm -rf /etc/paths.d/mono-commands

Source: http://www.mono-project.com/docs/about-mono/supported-platforms/osx/

 

 

Have you tried AppCleaner?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hi @deevo and @MsKittyKat just so you know I just updated to Mono 5.8.0 Stable (5.8.0.108) and all is still working fine. It installs fine right over the old version, no need to dig around to delete old mono versions. Macs will also keep older versions if they may be needed, so mine may actually be running of one of the older versions.

(Well now I cannot upload any screen shots)

But the other versions in the mono frameworks are

4.2.1

4.6.2

 

And yes @MsKittyKat the 3rd file is what your cleaner did not remove, it will be buried deep in the /var/db/BootCaches folders, NOT something you can go digging around for easily.

Partager ce message


Lien à poster
Partager sur d’autres sites

If only Mono version matched with the MS .Net Framework version. :rolleyes:

 

I hope to fix all these problems with version 2.
Thanks for your help. 

 

il y a 54 minutes, twmuse a dit :

Well now I cannot upload any screen shots

I send a message to the admin about this problem.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le ‎2018‎-‎02‎-‎12 à 14:28, deevo a dit :

If only Mono version matched with the MS .Net Framework version. :rolleyes:

 

@twmuse ok, great! Thanks for all your help!!! @deevo Yes I downloaded the AppCleaner, I'm currently running MonoFramework-MDK-5.2.0.macos10.xamarin.universal.pkg. So, I can't get the new S4ti to work....I guess I'm just screwed since it will take too much work to patch, huh?:triste5::triste5::triste5:

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×