Aller au contenu
Ce site utilise des cookies ! En apprendre plus

Ce site utilise des cookies !

Les cookies nous permettent de personnaliser le contenu et les annonces, d'offrir des fonctionnalités relatives aux médias sociaux et d'analyser notre trafic. Nous partageons également des informations sur l'utilisation de notre site avec nos partenaires de médias sociaux, de publicité et d'analyse, qui peuvent combiner celles-ci avec d'autres informations que vous leur avez fournies ou qu'ils ont collectées lors de votre utilisation de leurs services.

 

Pour en savoir plus sur la manière dont google utilise certaines données collectées cliquez sur le lien suivant : 

https://www.google.com/intl/fr/policies/privacy/partners/

 

Pour continuer d'utiliser ce site, vous devez accepter (en bas de la page) de nous permettre de stocker ces cookies sur votre ordinateur :) 

 

Vous trouverez ci dessous la liste des cookies et leur utilité :

Révélation

 

While some cookies will almost always be set by the Suite, there are some cookies that are set only in very specific circumstances.  If you have a need to identify all cookies the Suite may set, the following is a list of cookies and their intended purposes.

  • ips4_hasJS

This cookie is set by javascript and then later read to determine if javascript is supported in the user agent.

  • ips4_ipsTimezone

This cookie is set by javascript to detect the user's local time zone so that the software can adapt the displaying of times automatically.

  • ips4_IPSSessionFront

This is a session tracking cookie, used to track the user between page clicks.

  • ips4_member_id

This cookie would contain the user's member ID, used to "remember" the user in case their session ends between visits.

  • ips4_pass_hash

This cookie would contain a hash used to validate that the viewing user's member ID was not forged (it is not the actual password hash).

  • ips4_cms_filters (Pages only)

This cookie would track filters set by a user when filtering content in the Pages application.

  • ips4_ipsApprovalQueueSplash (Moderators only)

This cookie would track that a user has acknowledged the splash screen in the Moderator CP so that it is not shown again.

  • ips4_language (Guests only)

This cookie is used to track a language preference for a guest if the site has more than one language installed and the guest user chooses a specific language to use.

  • ips4_anon_login

This cookie is used to track a user's anonymous login preference if they choose this option during the login process.

  • ips4_theme (Guests only)

This cookie is used to track a theme preference for a guest if the site has more than one theme installed and the guest user chooses a specific theme to use.

  • ips4_ipbforumpass_XXX

When a forum has a specific password set, this cookie is set once a user logs in to that forum to validate that they have logged in on subsequent page loads.

  • ips4_thumbnailSize (Gallery only)

This cookie tracks what type of table layout to use in Gallery listings (list view, small thumbnails or large thumbnails)

Be aware that third party addons may set cookies as well, and that third party services integrated with the Suite (such as Google Analytics or Facebook Logins) may also set their own cookies.

 

 

 

deevo

S4TI - Public Beta (MacOS) - 2018-10-31

Messages recommandés

It's a bug!¬†ūüėģ

It appears that if you open the application menu while an attached dialog is open some items will keep the disabled state.

So completely restart S4TI then try to open the application menu to see if that fix the problem.

 

Edit: here's a new version with a possible fix
Sims4TrayImporter_20180528.zip

Partager ce message


Lien à poster
Partager sur d’autres sites

The link for the latest seems to be broken for me.

 

Well the last one works fine, must have been an ISP glitch, all seems working fine again in the Sims4TrayImporter_20180528.zip.

Partager ce message


Lien à poster
Partager sur d’autres sites

the last one you gave me allows me to debug. I got the following:

 

----------------------

App info...

----------------------

Version   :  0.9.6722.16604

Release   :  5/28/2018

 

----------------------

OS

----------------------

OSName    :  macOS High Sierra

OSVersion :  10.13

OSType    :  64bit

Process   :  32bit

 

----------------------

Game

----------------------

Product           :  The Sims 4

Locale            :  en_US

IsGameInstalled   :  False

InstallDir        :  /Applications/The Sims 4.app

InstallDirExists  :  False

UserDataDir       :  /Users/srblu/Documents/Electronic Arts/The Sims 4

UserDataDirExists :  True

FileCount         :  8

Modifié par lazycactus70

Partager ce message


Lien à poster
Partager sur d’autres sites

SO just an update here. i have changed the path to /applications/origin.app..

since this is where i have the game. Now when i debug it looks like this, but still no content. 

 

----------------------

App info...

----------------------

Version   :  0.9.6722.16604

Release   :  5/28/2018

 

----------------------

OS

----------------------

OSName    :  macOS High Sierra

OSVersion :  10.13

OSType    :  64bit

Process   :  32bit

 

----------------------

Game

----------------------

Product           :  The Sims 4

Locale            :  en_US

IsGameInstalled   :  False

InstallDir        :  /Applications/Origin.app

InstallDirExists  :  True

UserDataDir       :  /Users/srblu/Documents/Electronic Arts/The Sims 4

UserDataDirExists :  True

FileCount         :  8

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

That won't work, Origin is the manager, you must find the exact location of the game.

Try to get info about "The Sims 4" icon to see if you can get it location. Maybe it is located on a different disk? ūü§Ē

Partager ce message


Lien à poster
Partager sur d’autres sites

@lazycactus70 If you had origin install the game (which I assume since you have origin) it would have installed it in the same applications folder. If for some reason you changed the install folder in origin you can check that by starting origin, go to origin menu (just right of the apple) open preferences, then click on the Installs & Saves tab, in the On your computer section it will tell you where the game should be.

 

1768751137_ScreenShot2018-05-29at9_49_27AM.thumb.png.a89c3856f6811e39e18d01cae160226f.png

 

If for some reason you moved the game folder after install (which should not be done, origin likes thing in the applications folder) just do a search of the computer for  the sims 4, and the application will come up in the list.

259213544_ScreenShot2018-05-29at9_52_25AM.png.2687933f18f9f6b0f3b4a325b3cf065f.png

Partager ce message


Lien à poster
Partager sur d’autres sites

@lazycactus70  Glad that helped, I had many issues with the sims 4 and add ons, until I deleted the whole thing and let origin reinstall it in the default location, working like a charm since then.

Partager ce message


Lien à poster
Partager sur d’autres sites

well i thought everything had been solved, but i went to go use the app and its only showing me my households from the 23rd for some reason. i have made a new household since then and edited the past ones but those aren't showing up? 

Partager ce message


Lien à poster
Partager sur d’autres sites

@lazycactus70 Open your Tray folder then count the number of .trayitem file, it should match the number displayed at bottom of S4TI.

Or open the Debug box then compare the row FileCount with what S4TI reports.

Partager ce message


Lien à poster
Partager sur d’autres sites
On 5/27/2018 at 9:07 PM, deevo said:

Ok, I put back the old config box since the new one is far from ready for Mac.

I hope this one will work again!¬†ūüôÉ

Sims4TrayImporter_20180527-3.zip

 

The May update only fix the crash from this post and was going to introduce a new config box, but look like it failed.¬†ūüôĄ

 

Hey again! How do I access this link? x

Partager ce message


Lien à poster
Partager sur d’autres sites

Nouvelle beta ! ūüôā

 

Vous pouvez maintenant importer/exporter vos param√®tres, ce qui devrait vous aider √† d√©marrer en quelques secondes !¬†ūüėč

Le contenu des listes devraient mieux s'ajuster !

La biblioth√®que vient tout juste de recevoir son propre menu.¬† Note: Afficher le menu pour des √©l√©ments non s√©lectionn√©s peut produire des r√©sultat inattendus. ūüėä

 

English

New beta here! ūüôā

 

You can now import/export your settings, which should help you get started in seconds!¬†ūüėč

The contents of the lists should adjust a little better!

The library has just received a menu. Note: Showing the menu on unselected items may produce unpredictable results.¬†ūüėä

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello @twmuse,

 

Can you confirm a high memory leak on your side?¬†ūü§Ē

Scrolling the library will quickly increase memory usage while it should be almost stable.

Memory usage should be around 50MB with some peaks at ~100MB.

Partager ce message


Lien à poster
Partager sur d’autres sites

Hi @deevo,

 

Well, did a check, and yes but much more then ~100MB, I think it may be tied to the size of the library, mine went from about 66MB, after scrolling the entire library jumped to around 586MB.

 

 

Screen Shot 2018-09-13 at 3.29.47 PM.png

Screen Shot 2018-09-13 at 3.28.53 PM.png

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, twmuse a dit :

Well, did a check, and yes but much more then ~100MB, I think it may be tied to the size of the library, mine went from about 66MB, after scrolling the entire library jumped to around 586MB.

Thanks for your reply,

I get the same result on Windows, but ~3 times the size with about the same number of items. Maybe because some items are skipped while scrolling? ūü§Ē

 

Anyway I already figured out the problem and it's the thumbnail caching.

By disabling image caching the memory usage drops to ~50MB-~80MB and there doesn't seem to have any performance hit! So turning off image caching will be!¬†ūüôā

 

Sorry for the confusion, the 50MB and ~100MB were for a normal operation, no memory leak.¬†ūüėČ

Partager ce message


Lien à poster
Partager sur d’autres sites

Nouvelle beta ! ūüôā

 

Vous pouvez maintenant importer/exporter vos param√®tres (cette fois √ßa devrait fonctionner) !¬†ūüėč

Correction du problème de mémoire.

Chargement des images en arrière-plan.

64bits !

 

Si vous avez des probl√®mes pour lancer l'application, essayer de t√©l√©charger la version de Mono pour Visual Studio.¬†ūüėČ

 

English

New beta here! ūüôā

 

You can now import/export your settings (yess, this time it should work)!¬†ūüėč

Fixed the high memory usage.

Load images in background.

64-bit!

 

If you have some troubles running this application, try Mono for Visual Studio.¬†ūüėČ

Partager ce message


Lien à poster
Partager sur d’autres sites

@deevo  Thanks for the update, working just fine, on latest macOS Mojave 10.14, memory stays within 100mb scrolling through the whole library.

Modifié par twmuse

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

√ó