Jump to content

Recommended Posts

  • Replies 165
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

*** Nevermind! I kept looking for it in the thread but I found the answer.   I followed the above steps but am still having some issues.   When I open the program a window titled "

just did and it works again thank you!

Thank you so much! I can finally clean out my friends stupid mods :))))))))))))))))) Also, thank you for replying quickly yay me

Posted Images

Hey! So I've currently got the latest version of Sierra, the mono framework, and Tray Importer (from July) for mac downloaded, and I can open the program, except before any of the files can load the program just stops responding every time. I've tried launching through terminal, installing and reinstalling the program + framework, and it just won't respond. Anyone have any tips? 

Thank you x

Link to post
Share on other sites

Yes this is a bug I am aware.
The list seems to load at once the entire library including the thumbnails which cause the program to stop responding.

This only affects Mac users, on Windows the problem is not as such important.

 

Unfortunatly I can't fix it for sure without a Mac! :(

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

I have done every single step that it has told me to do twice by reinstalling and uninstalling. I don't understand how to make the Debug thing turn to True and not False. Someone please help all I want to do is delete some ugly CC I don't want! Please help me ASAP! :1f62d: I'm getting very frustrated and stressed!

Link to post
Share on other sites

Hi @Saiige,

If your game is not installed in the default folder, it will fail to find it!

 

The Config Path will not work without an elevated account 'cause OSX don't like modifications in app folder.

You can manually edit the file Sims4.GameInfos.Settings.xml to get around this bug.

 

I will try to move the settings file in the doc folder, which should temporary fix this bug.

 


@Shaynemay20 The Drop file here is not available on Mac since the toolkit is too much limited.

If Nothing show up, run the Debug tool or try to manually set the paths.

 

 

Update:  I found the bug, the file was saved in the wrong folder! :blush:

              A new version is available here: http://luniversims.com/forums/topic/5970-s4ti-public-beta-macosx/

 

Link to post
Share on other sites

@Saiige The default Xml file is stored in the app folder, you need to open it and browse to Contents/MonoBundle.

 

Did you download the latest beta?

It should fix the bug where changes are not saved when trying to redefine the paths using the Config Path dialog. 

Link to post
Share on other sites

Ok, so I found the app folder and I'm in it but when I search through it there is no Monobundle or Sims4TrayImporter.

Also, mine says Alpha not beta does that make a difference?

 

Ok never mind, I just found the Monobundle folder and i'm in it. What do I do now?

Link to post
Share on other sites

@Saiige Have you tryed to redefine the path using the Config Path dialog? It should be fixed now, so no need to edit the xml file.

 

But just in case it still don't work, open the xml file:

- InstallDir should point to the Game folder (ex: /Applications/The Sims 4.app/)

- Locale must match the game language else it won't find your save folder in Documents. 

<?xml version="1.0" encoding="utf-8" ?>
<Sims4.GameInfos.Settings>
  <GameInstallation>
    <Name>The Sims 4</Name>
    <Locale>en_US</Locale>
    <DisplayName>The Sims™ 4</DisplayName>
    <InstallDir>/Applications/The Sims 4.app/</InstallDir>
    <Version>1.0.0.0</Version>
    <ExePath>[InstallDir]Contents/MacOS/The Sims 4</ExePath>
  </GameInstallation>
</Sims4.GameInfos.Settings>

 

A newer version is now available! http://luniversims.com/forums/topic/5970-s4ti-public-beta-macosx/

Link to post
Share on other sites

Hello, I've read through several forums and i just can't figure it out... I can download the application just fine but my library does not load when I load up S4TI. I know this is annoying since people have explained it so many times but I am completely lost, is there any way someone who had my same problem who figured it out can make a video explaining it on youtube? It would really help me out if i could just see how to get to all of the files and stuff visually... if anyone can thank you it is much appreciated 

Link to post
Share on other sites

Ok, so the other day I found the folder with all the stuff but now I can't find it.. and I don't understand what you mean by you made a new version. Every time I try to re-install it, it's just the same thing where how my library doesn't load.. this is so so so so confusing it would be easier with a video, do you know any that are for Mac and have a solution to the problem I'm having?

Link to post
Share on other sites
Just now, Saiige said:

Ok, so the other day I found the folder with all the stuff but now I can't find it.. and I don't understand what you mean by you made a new version. Every time I try to re-install it, it's just the same thing where how my library doesn't load.. this is so so so so confusing it would be easier with a video, do you know any that are for Mac and have a solution to the problem I'm having?

I'm having the same exact problem

Link to post
Share on other sites

Sorry I'm not a Mac user, but you can search over the net to find some good video tutorial.

The easiest way to fix the problem is to install the game in the default location (/Applications/The Sims 4.app), but you may run out of space.

 

 

Fixing S4TI:

If you can't find the XML, just create a new one.

 

*Go to your Documents folder then create folder Sims 4 Tray Importer if not exists.

Create a file with the name Sims4.GameInfos.Settings.xml then paste this :

<?xml version="1.0" encoding="utf-8" ?>
<Sims4.GameInfos.Settings>
  <GameInstallation>
    <Name>The Sims 4</Name>
    <Locale>en_US</Locale>
    <DisplayName>The Sims™ 4</DisplayName>
    <InstallDir>/Applications/The Sims 4.app/</InstallDir>
    <Version>1.0.0.0</Version>
    <ExePath>[InstallDir]Contents/MacOS/The Sims 4</ExePath>
  </GameInstallation>
</Sims4.GameInfos.Settings>

Then edit InstallDir and Locale.

 

* You'll still need the lastest unofficial version for this to work.

For older versions :

Go to ~/Library/Application Support/Sims 4 Tray Importer/

The bug only affects the saving, so editing the xml file from this location will work.

Link to post
Share on other sites

@Saiige The code say that the path will be created as soon it is requested.

But I think that the older versions use ~/Library/Preferences/Sims 4 Tray Importer so it may explain why ~/Library/Application Support/Sims 4 Tray Importer doesn't work.

 

The folder may be empty at first, you'll need to create the Sims4.GameInfos.Settings.xml manually.

 

Did you try the latest unofficial version? It should fix the Config Path bug where changes are not saved and you won't have to dig in all this trouble.

Link to post
Share on other sites
  • 2 weeks later...

Hi, I need major help. I tried a million times to reinstall mono AND the sims 4 tray importer and it doesn't work at all. Every time I try to open the Tray Importer it says "The application can't be opened."

I tried your "application not open" link suggestion and that does nothing. I'm using macOS Sierra version 10.12.6.

 

Screen Shot 2017-10-20 at 11.04.23 AM.png

 

 

 

Link to post
Share on other sites

Hi @emylacy, have you tried this  

 

On Sierra you must allow apps from unknown source to run. Watch the video on the post.

You can also try to run it through the terminal.

 

*Be cautious when posting images that contains private information. ;)

Link to post
Share on other sites

I did, I tried to watch every install tutorial for Mac computers on youtube. None helped my problem. I also tried the terminal suggestion and that also didn't work

Also, what private information did I share? lolol

Edited by emylacy
Link to post
Share on other sites

@emylacy Have you tried the fix from the apple forum on the same post?

 

Il y a 5 heures, emylacy a dit :

Also, what private information did I share? lolol

There was a Serial Number at the bottom of the screenshot. Not sure if it is really private, but better not take a chance. ^_^

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy