Jump to content

Recommended Posts

0.pngSome Mac users have been experiencing issues with Sims 4 Tray Importer since upgrading to macOS Sierra. 

For example:

-- The application "bounces" in the Dock and then disappears.

-- Mono Framework doesn't work.

-- The application cannot find The Sims 4 files.

This tutorial will show you how to install and run S4TI correctly.

 

 

 

1. Download the required files

Firstly, you need to download both Sims 4 Tray Importer and Mono Framework. 

 

3.png

@deevo has uploaded an updated version of S4TI for Sierra HERE that includes a debug window. I suggest that you download that option as seen to the left.

Update: It's recommended to download the latest release version from here.

 

 

 

Next, download Mono Framework. You must download the Universal Installer or the application will not work.

There are two sources available to download the framework from. They should both work the same way, but if you don't have success with one, try the other.
Update: Latest version require Mono 5.16 (macOS 10.9+) or 5.18 (macOS 10.12+), other versions of Mono might not work with the current version.

 

Source 1: HERE

1.png

 

 

 

 

 

 

 

 

Source 2: HERE

2.png

 

 

 

 

 

 

 

 

2. Install files

Secondly, you need to install the files that you've just downloaded. Some think that you only need to download the Universal Installer to use it. However, you do indeed need to install it.

 

4.png You should have two files in your Downloads folder that look similar to those on the left.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5.pngBegin by opening the Mono Framework file. You will be directed through the installer. Follow the prompts until finished (just hit the "continue" button over and over again, really).

 

 

 

 

 

 

 

 

 

 

 

 

 

7.pngOnce you have installed the framework, unzip the S4TI file that you downloaded. The application will now appear in your downloads. If you try to open it from this location it will not work. Click and drag S4TI into your Applications folder.

 

 

 

 

 

 

 

3. Open and enjoy!

 

10.pngOpen the application. This may take a few moments as the application loads your library. Happy Simming! 

 

 

 

 

 

 

 

 

 

 

If S4TI does not load your library:

-- Take a look at the debug window (S4TI > Debug). No lines should be blank and you should see the word "True" in three locations. If you happen to see the word "False", this is your issue. The application is having difficulty finding the location of an aspect of your game. 

-- Try changing file locations (S4TI > Select Game Folder).

-- Reinstall your game. Make sure to backup your saves, Tray, Mods, etc!

-- Take a look at THIS POST for more information. 

Edited by deevo
Added recommendations
  • Like 2

Share this post


Link to post
Share on other sites

I have a problem...

Everything works perfectly fine until I try and open the application. It bounces in the dock, opens for half a second, then disappears. Please help me out with this!!

Share this post


Link to post
Share on other sites

This is a bug with the toolkit. it just can't find itself! :ermm:

 

Try to launch the app as admin to see if it make any differences.

 

You may even try to launch it from the Terminal with the command:

 mono Sims4TrayImporter.app/Contents/MonoBundle/Sims4TrayImporter.exe

Share this post


Link to post
Share on other sites

If not already, try the latest beta.

Unfortunately, the hardest part is to make it run on Sierra. :ermm:

 

You may even try the hint from here. (Eto.Forms is the front end used for the Mac port)

Share this post


Link to post
Share on other sites

:(:( Im unable to figure out how to  delete CC.It launches and i can delete tray files because it routes directly to them, but the cc section just opens the mod folder no matter which cc item i select.   #mac #helpplease

Edited by Ashlee Oww
help tag attachment

Share this post


Link to post
Share on other sites

Hi @tiniyah,

 

I wish I could get a Mac so that I could assist you, but unfortunately I can't afford it! :crying:

 

Maybe if someone repack the app in a DMG that would fix those problems? :ermm:

Share this post


Link to post
Share on other sites
2 hours ago, deevo said:

Hi @tiniyah,

 

I wish I could get a Mac so that I could assist you, but unfortunately I can't afford it! :crying:

 

Maybe if someone repack the app in a DMG that would fix those problems? :ermm:

i mainly want to reduce the lag in my game (im not expecting it to be perfect on a macbook air), any tips? i have a system cleaner that sometimes helps and i took a good amount of my cc out already

Share this post


Link to post
Share on other sites
il y a 2 minutes, tiniyah a dit :

i mainly want to reduce the lag in my game (im not expecting it to be perfect on a macbook air), any tips?

 

Which version of Mono have you installed?

If you are running El Capitan or Sierra make sure you are not installing Mono in rooted mode (/user/bin/mono) else it may not work.

If this is the case, just uninstall Mono then reinstall it using the latest version.

Share this post


Link to post
Share on other sites
il y a une heure, tiniyah a dit :

ive tried every version in this thread and i just tried that and got the same message :(

What is the message?

 

Did you remove previous version before installing a new Mono version?

 

You may try Sims 4 Studio to browse your CCs.

Share this post


Link to post
Share on other sites

Hi. I have been having issues with this and I haven´t found an answer in the comments. I have installed the new version of mono and I got the latest version f the Sims 4 Tray Imported but as soon as I click on the app on Finder a message comes up saying: The application “Sims4TrayImporter” can’t be opened. Help?

Share this post


Link to post
Share on other sites

Hi @carolineismystyle123,

 

The message just say that the program was not properly registered as launchable.

The latest version should allow you to launch the app using terminal.

 

There's a video here for basic installation...

https://www.youtube.com/watch?v=Q4tRNUqyd_w

 

And to fix the launch bug...

https://discussions.apple.com/thread/7586240?start=0&tstart=0

Share this post


Link to post
Share on other sites

Hey @deevo I have an updated mac - version 10.11.6 and the program downloaded fine. However, when I go to use it nothing comes up from my sims 4 game (the cc). Is it cus i am too updated? 

 

Thanks for the help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy