Jump to content
  • Sign Up
  • Language

CC not showing up in Sims 4 Tray Importer


Mely Aguilera

Recommended Posts

  • Team

Hi,

 

You are one of those rare cases where S4TI fails to find the game.

Please check the 'HELP>Game Info Debugging' to find out where S4TI fails and send me the result.

 

You may also try this solution :

  • Edit the settings file:
    • Go to the folder where S4TI was installed. (right-click on the app shortcut and select Open file location)
    • Find the file Sims4.GameInfos.Settings.xml and open it.
      Révélation

      If the file does not exist, create a file with the name Sims4.GameInfos.Settings.xml and paste the following content :

      
      <?xml version="1.0" encoding="utf-8" ?>
      <Sims4.GameInfos.Settings>
        <GameInstallation>
          <Name>The Sims 4</Name>
          <Locale>[Auto]</Locale>
          <DisplayName>The Sims™ 4</DisplayName>
          <InstallDir>%ProgramFiles%\Origin Games\The Sims 4\</InstallDir>
          <Version>1.0.0.0</Version>
          <ExePath>[InstallDir]Game\Bin\TS4.exe</ExePath>
        </GameInstallation>
      </Sims4.GameInfos.Settings>
    • Edit the value of InstallDir to the current path where the game is installed.
    • Edit the value of Locale to the language used in game or leave it to [Auto] to let S4TI detect the language based on your system settings and the available resources.
    • Save the changes.
  • Allow S4TI to use the XML:
    • Right-click on the S4TI shortcut and select Properties.
    • Select the Shortcut tab if not selected (usually the 2nd tab from the left).
    • Edit the value of Target field (usually the 1st editable one) and append ' -userPath -noGameCheck' without the quotes.
      eg: "C:\Program Files (x86)\Sims 4 Tray Importer\Sims4TrayImporter.exe" -userPath -noGameCheck
      -noGameCheck is optional, but may help if the app fails to find the game by using the custom path. This will also display a message at each launch.
    • Click Apply or OK to save the change.

 

Link to comment
Share on other sites

  • 3 weeks later...

Hi, I have the same problem, this is  my error log, please help

 

Révélation

 

Begin Reading


OS infos...
------------------------------

OSName   : Windows 10
OSVersion: 10.0.10586.0
OSType   : 64-bit
Process  : 32-bit


Opening Registry...
------------------------------

Reading .NET Framework version...
.NET Framework Version: 4


Opening Registry...
------------------------------

Listing keys for HKLM\SOFTWARE\Maxis:
// note: 32-bit node
[\The Sims 4]
 Locale       = en_US
>>>> [Warning] ProductGuid not found !
// note: 64-bit node
>>>> [Error] key not found !


Reading Game infos...
------------------------------

[The Sims 4 Installation]
Name          : The Sims 4
Version       : 1.0.0.0
DisplayName   : The Sims™ 4
Locale        : en_US
InstallDir    : 
IsInstalled   : False

>>>> [Error] Something goes wrong while detecting your game installation


Done!

 

 

 

Thank you

Link to comment
Share on other sites

  • 2 weeks later...
  • Team

Make sure the proper language is set, if not set properly it won't find the Save folder.

(en_US = 'Documents\Electronic Arts\The Sims 4' while fr_FR = 'Documents\Electronic Arts\Les Sims 4')

 

You may also try without the part 'Contents/' or with the full path '/Applications/The Sims 4.app/Contents/MacOS/The Sims 4'. Or manually select each path by clicking on the '...' button.

Link to comment
Share on other sites

  • Team

Just change the value of ExecutablePath and leave InstallDir unchanged.

By changing the value of InstallDir, the value of ExecutablePath is also updated.

 

There is a bug in this release, the 'Contents/' part will be added twice to the ExecutablePath.

Since InstallDir already contains 'Contents/', if ExecutablePath also include 'Contents/' it won't find the file until you remove it from the path.

 

 

For the values that seem to revert back to the default ones, I think it's because the values are not read.  Atleast they are saved, but not read !

You can open the file Sims4.GameInfos.Settings.xml to confirm that your changes has been saved.

 

So just make sure to edit ExecutablePath after editing InstallDir and not the reverse.

Link to comment
Share on other sites

  • 3 months later...
Le 7/7/2016 à 15:15, deevo a dit :

Hi,

 

You are one of those rare cases where S4TI fails to find the game.

Please check the 'HELP>Game Info Debugging' to find out where S4TI fails and send me the result.

 

You may also try this solution :

  • Edit the settings file:
    • Go to the folder where S4TI was installed. (right-click on the app shortcut and select Open file location)
    • Find the file Sims4.GameInfos.Settings.xml and open it.
        Révéler le contenu masqué

      If the file does not exist, create a file with the name Sims4.GameInfos.Settings.xml and paste the following content :

      
      
      <?xml version="1.0" encoding="utf-8" ?>
      <Sims4.GameInfos.Settings>
        <GameInstallation>
          <Name>The Sims 4</Name>
          <Locale>[Auto]</Locale>
          <DisplayName>The Sims™ 4</DisplayName>
          <InstallDir>%ProgramFiles%\Origin Games\The Sims 4\</InstallDir>
          <Version>1.0.0.0</Version>
          <ExePath>[InstallDir]Game\Bin\TS4.exe</ExePath>
        </GameInstallation>
      </Sims4.GameInfos.Settings>
    • Edit the value of InstallDir to the current path where the game is installed.
    • Edit the value of Locale to the language used in game or leave it to [Auto] to let S4TI detect the language based on your system settings and the available resources.
    • Save the changes.
  • Allow S4TI to use the XML:
    • Right-click on the S4TI shortcut and select Properties.
    • Select the Shortcut tab if not selected (usually the 2nd tab from the left).
    • Edit the value of Target field (usually the 1st editable one) and append ' -userPath -noGameCheck' without the quotes.
      eg: "C:\Program Files (x86)\Sims 4 Tray Importer\Sims4TrayImporter.exe" -userPath -noGameCheck
      -noGameCheck is optional, but may help if the app fails to find the game by using the custom path. This will also display a message at each launch.
    • Click Apply or OK to save the change.

 

I had the same problem, but this fixed it. Thanks a lot!!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy