Jump to content
Ce site utilise des cookies ! En apprendre plus

Ce site utilise des cookies !

Les cookies nous permettent de personnaliser le contenu et les annonces, d'offrir des fonctionnalités relatives aux médias sociaux et d'analyser notre trafic. Nous partageons également des informations sur l'utilisation de notre site avec nos partenaires de médias sociaux, de publicité et d'analyse, qui peuvent combiner celles-ci avec d'autres informations que vous leur avez fournies ou qu'ils ont collectées lors de votre utilisation de leurs services.


Pour en savoir plus sur la manière dont google utilise certaines données collectées cliquez sur le lien suivant : 



Pour continuer d'utiliser ce site, vous devez accepter (en bas de la page) de nous permettre de stocker ces cookies sur votre ordinateur :) 


Vous trouverez ci dessous la liste des cookies et leur utilité :



While some cookies will almost always be set by the Suite, there are some cookies that are set only in very specific circumstances.  If you have a need to identify all cookies the Suite may set, the following is a list of cookies and their intended purposes.

  • ips4_hasJS

This cookie is set by javascript and then later read to determine if javascript is supported in the user agent.

  • ips4_ipsTimezone

This cookie is set by javascript to detect the user's local time zone so that the software can adapt the displaying of times automatically.

  • ips4_IPSSessionFront

This is a session tracking cookie, used to track the user between page clicks.

  • ips4_member_id

This cookie would contain the user's member ID, used to "remember" the user in case their session ends between visits.

  • ips4_pass_hash

This cookie would contain a hash used to validate that the viewing user's member ID was not forged (it is not the actual password hash).

  • ips4_cms_filters (Pages only)

This cookie would track filters set by a user when filtering content in the Pages application.

  • ips4_ipsApprovalQueueSplash (Moderators only)

This cookie would track that a user has acknowledged the splash screen in the Moderator CP so that it is not shown again.

  • ips4_language (Guests only)

This cookie is used to track a language preference for a guest if the site has more than one language installed and the guest user chooses a specific language to use.

  • ips4_anon_login

This cookie is used to track a user's anonymous login preference if they choose this option during the login process.

  • ips4_theme (Guests only)

This cookie is used to track a theme preference for a guest if the site has more than one theme installed and the guest user chooses a specific theme to use.

  • ips4_ipbforumpass_XXX

When a forum has a specific password set, this cookie is set once a user logs in to that forum to validate that they have logged in on subsequent page loads.

  • ips4_thumbnailSize (Gallery only)

This cookie tracks what type of table layout to use in Gallery listings (list view, small thumbnails or large thumbnails)

Be aware that third party addons may set cookies as well, and that third party services integrated with the Suite (such as Google Analytics or Facebook Logins) may also set their own cookies.





[Application]Sims 4 Tray Importer for Mac

Recommended Posts

Sims 4 Tray Importer for Mac

Cette application permet d'extraire ou d'importer du contenu SIMS 4 (Maisons, Terrains, Sims ou Pièces) depuis (ou vers) votre bibliothèque.


C'est le pendant de la version Windows, mais pour MAC.



Prérequis d’installation :


MacOS 10.9+

Mono 5.10.1+ ( 5.18 nécessite macOS 10.12+ )


Pour connaître votre version MacOS, suivez le guide : [Guide] SIMS 4 Tray Importer MAC Français

Vous pouvez aussi suivre le Guide d'installation anglais qui est beaucoup plus court. (voir plus bas)


Téléchargement et installation de l’application


Cette étape se fait en 2 temps :

● Installation de l'application

  ◦ Télécharger Sims4TrayImporter

  ◦ Extraire l'application (double-clic sur le fichier télécharger)
  ◦ Déplacer l'application dans /Applications (optionnel)


● Installation du composant « Mono », qui permet d'utiliser S4TI pour MAC

  ◦ Télécharger Mono (récupérer la version Visual Studio channel si vous n'êtes pas certains)

  Lancer l'installation et suivre les indications



Note : 

Si vous recevez un message semblable à « Impossible d'ouvrir "Sims4TrayImporter" »  lorsque vous tentez de lancer l'application avec un double-clic :
Dans Finder cliquer sur l'icône de l'application tout en maintenant Contrôle (ou clic-droit) puis sélectionner Ouvrir.

Si ça ne fonctionne pas essayer d'enregistrer manuellement l'exécutable à l'aide de la commande suivante (par fois il faut l'appeler 2 fois pour que ça fonctionne) :

chmod +x /Applications/Sims4TrayImporter.app/Contents/MacOS/Sims4TrayImporter



Attention : les Guides ne sont peut-être plus à jour.
Suivez le guide d'installation pour connaître en détail les étapes d'installation

Pour toutes questions, merci de vous rendre sur le forum Sims 4 Tray Importer


Share this post

Link to post
Share on other sites

Have you upgraded to Sierra?

If so, Gatekeeper may cause troubles with unsigned apps by blocking them.


I don't own a Mac, so I can't check if it still works. :ermm:

Share this post

Link to post
Share on other sites

Make sure the folder is named Sims4TrayImporter.app.


Sometime the launcher is not registered, so try this command in the terminal :

chmod +x Sims4TrayImporter.app/Contents/MacOS/Launcher.exec

Replace 'Sims4TrayImporter.app/' with the current path where the app was extracted.

Share this post

Link to post
Share on other sites

I tried using the command in terminal and it said:


Stephs-MacBook-Pro:~ Steph$ chmod +x Sims4TrayImporter.app/Contents/MacOS/Launcher.exec

chmod: Sims4TrayImporter.app/Contents/MacOS/Launcher.exec: No such file or directory

The app actually opened but it wasn't responding then it crashed and now every time i try opening it, it does open but it immediately closes :( 

Share this post

Link to post
Share on other sites

This is probably because the path is incomplete.  What is the full path?

You may also try to move it to the /Applications folder and see if it work better.




@Bouckie les images pour la procédure d'installation semblent avoir disparu ? :(

Share this post

Link to post
Share on other sites

Hello, I have Captain 10.11.6 and when I try opening Sims4TrayImporter, the icon shows up in the dock and then disappears. It never opens and I don't know what to do. I tried running in terminal and nothing happened (theres a photo). Any advice :(?
I dowloaded Mono, but i don't know if i have to run something special or whatever, because i can't find specific instructions for Sims4TrayImporter. Thanks!

Screen Shot 2016-11-24 at 3.38.30 PM.png

Share this post

Link to post
Share on other sites

The download page is broken, but the Instructions are here (use Google to translate). :rolleyes:


The launcher seem to cause lot of troubles, but I don't have a Mac to find and fix the problem. :(

You may try to launch the app directly from 'Sims4TrayImporter.app/Contents/MonoBundle/Sims4TrayImporter.exe' with mono from the terminal.


An alternative would be to boot camp to Windows or to try WineBottler and the Tray Importer for Windows XP.

Share this post

Link to post
Share on other sites


Try one of the following commands:

open -a Sims4TrayImporter.app
% MONO_PATH=. mono Sims4TrayImporter.exe
% MONO_PATH=/usr/bin/mono mono Sims4TrayImporter.exe
% MONO_PATH=/usr/local/bin/mono mono Sims4TrayImporter.exe


You may also check these:

ls -l /Application/Sims4TrayImporter.app and check that is flagged as executable

ls -l /Application/Sims4TrayImporter.app/Contents/MacOS/Launcher.exec and check that is flagged as executable



Or even replace the Launcher.exec with the following script:


cd "$APP_PATH/Contents/Resources"

if [ "$X11_MODE" -eq "1" ]; then
        open-x11 "$APP_NAME"
        if [ -f "/usr/local/bin/mono" ]; then MONO_PATH="/usr/local/bin/mono" ; fi
        "$MONO_PATH" "$ASSEMBLY"

You may need to set the executable flag on the new script.

Share this post

Link to post
Share on other sites

will this ever be updated to work with the current version of Sierra? i was able to use it for a little while back when i still had el capitan, updated when sierra came out, not realizing it would break this, and have never been able to get it to work again. 

Share this post

Link to post
Share on other sites


The current version supports Sierra, you can also try the latest beta.

The problem may come from the Mono Framework, the Eto toolkit or even the way the app was unpacked, but I don't have access to a Mac to look at the problem.

You may find some useful informations here.


One thing you can try is running the Windows version with Wine which should enable almost all the features of the Windows port.

This was not tested, but if you go the Wine way, you will need the full .Net Framework and not Mono.

An easier method is PlayOnMac which come bundled with Wine and should make things easier to setup.

Share this post

Link to post
Share on other sites

thank you for the quick reply! unfortunately even the latest beta freezes and has to be force quit with sierra 10.12.4. i wish i knew anything about programming and could help figure out what's going on, but i'm completely useless here. 


i've tried using wine but wasn't successful (possibly because i didn't really know what i was doing) and i had never heard of PlayOnMac until now, so i'm giving that a try currently! unfortunately my first few attempts gave me an error saying the current windows version of the tray importer wasn't compatible with the version of windows with playonmac. 

Share this post

Link to post
Share on other sites


If Wine is setup to emulate Windows XP, you should download the XP version.
The XP version is more compatible and will work on all Windows versions as it only require the .Net Framework 4.0.

You may receive a not designed for message, but you can safely ignore it.


For other versions, the non XP version should work, but require .Net Framework 4.5.2.




Share this post

Link to post
Share on other sites

If anyone checks this thread anymore, would anyone mind helping me? My s4ti does manage to open, but its all blank. There's no households/rooms/etc of mine and i'm not sure what to do from here on :(

Share this post

Link to post
Share on other sites

hey i just wanted to say with the latest update, this now works for me! thank you very much for continuing to work on this, now i can get rid of some of the cc i'm not fond of anymore. 

  • Like 1

Share this post

Link to post
Share on other sites

My TrayImporter opens perfectly, but when I go to click on one of the sims that I created to get rid of cc, it crashes every time!! What can be done to stop this?? 

Share this post

Link to post
Share on other sites

can i get the old link of the previous one for mac , it worked for me as long as I opened a certain way . and i need to get of cc that i cant find .. PLEASE HELP!

Share this post

Link to post
Share on other sites

Hello. What program do you use to find conflict mods? Do not have Mod Conflict for Mac?

Thank you in advance. i pursue my researches streaming ....








Edited by zimou13

Share this post

Link to post
Share on other sites

I spooke to someone previously and I downloaded the beta version but now nothing shows up .. I don't know what I did wrong when I downloaded it.. 


Heres a picture to show what Im talking about ...5a8f30e5c52c9_ScreenShot2018-02-22at4_01_59PM.png.c0ce8f673c0a1289d7a9389c5b70d219.png

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...