Aller au contenu
Ce site utilise des cookies ! En apprendre plus

Ce site utilise des cookies !

Les cookies nous permettent de personnaliser le contenu et les annonces, d'offrir des fonctionnalités relatives aux médias sociaux et d'analyser notre trafic. Nous partageons également des informations sur l'utilisation de notre site avec nos partenaires de médias sociaux, de publicité et d'analyse, qui peuvent combiner celles-ci avec d'autres informations que vous leur avez fournies ou qu'ils ont collectées lors de votre utilisation de leurs services.

 

Pour en savoir plus sur la manière dont google utilise certaines données collectées cliquez sur le lien suivant : 

https://www.google.com/intl/fr/policies/privacy/partners/

 

Pour continuer d'utiliser ce site, vous devez accepter (en bas de la page) de nous permettre de stocker ces cookies sur votre ordinateur :) 

 

Vous trouverez ci dessous la liste des cookies et leur utilité :

Révélation

 

While some cookies will almost always be set by the Suite, there are some cookies that are set only in very specific circumstances.  If you have a need to identify all cookies the Suite may set, the following is a list of cookies and their intended purposes.

  • ips4_hasJS

This cookie is set by javascript and then later read to determine if javascript is supported in the user agent.

  • ips4_ipsTimezone

This cookie is set by javascript to detect the user's local time zone so that the software can adapt the displaying of times automatically.

  • ips4_IPSSessionFront

This is a session tracking cookie, used to track the user between page clicks.

  • ips4_member_id

This cookie would contain the user's member ID, used to "remember" the user in case their session ends between visits.

  • ips4_pass_hash

This cookie would contain a hash used to validate that the viewing user's member ID was not forged (it is not the actual password hash).

  • ips4_cms_filters (Pages only)

This cookie would track filters set by a user when filtering content in the Pages application.

  • ips4_ipsApprovalQueueSplash (Moderators only)

This cookie would track that a user has acknowledged the splash screen in the Moderator CP so that it is not shown again.

  • ips4_language (Guests only)

This cookie is used to track a language preference for a guest if the site has more than one language installed and the guest user chooses a specific language to use.

  • ips4_anon_login

This cookie is used to track a user's anonymous login preference if they choose this option during the login process.

  • ips4_theme (Guests only)

This cookie is used to track a theme preference for a guest if the site has more than one theme installed and the guest user chooses a specific theme to use.

  • ips4_ipbforumpass_XXX

When a forum has a specific password set, this cookie is set once a user logs in to that forum to validate that they have logged in on subsequent page loads.

  • ips4_thumbnailSize (Gallery only)

This cookie tracks what type of table layout to use in Gallery listings (list view, small thumbnails or large thumbnails)

Be aware that third party addons may set cookies as well, and that third party services integrated with the Suite (such as Google Analytics or Facebook Logins) may also set their own cookies.

 

 

 

deevo

S4TI - Public Beta (MacOS)

Messages recommandés

@deevo Well sorry to be the bearer of bad news, but this last test version crashes like the last 2. And on top of that when selecting a household in the library,the main window no longer shows any pictures when on the general tab.

 

Now for a little longer test info.

 

I went back to the "working version" Sims4TrayImporter_20170710 : This one lets me get through all households as long as I put the tab back on general before picking a new household (left on cc or files tab and it crashes)

 

Sims4TrayImporter_20170930 and last 2 "Test" builds, crash the second you try and pick a new household in the library, no matter what tab you have selected (once you pick the cc tab). i.e. I can go through all households, as long as I do not hit the cc tab for any of them. Once you pick the cc tab, the next household picked from the library will crash.

 

Side Note: I tried to do the windows version on a VM, but will not work due to the missing .dll's that the mac sims folder must not have, so I assume Wine would not work either.

Modifié par twmuse

Partager ce message


Lien à poster
Partager sur d’autres sites

So I think I'm done with that toolkit unless I rewrite everything! :(

 

il y a 40 minutes, twmuse a dit :

Sims4TrayImporter_20170930 and last 2 "Test" builds, crash the second you try and pick a new household in the library, no matter what tab you have selected (once you pick the cc tab). i.e. I can go through all households, as long as I do not hit the cc tab for any of them. Once you pick the cc tab, the next household picked from the library will crash.

I almost know what is causing the problem, but it appears to be a Mono issue, whenever a null reference it encountered it crashes while it shouldn't.

 

il y a 45 minutes, twmuse a dit :

Side Note: I tried to do the windows version on a VM, but will not work due to the missing .dll's that the mac sims folder must not have, so I assume Wine would not work either.

What is the missing .dll?
The Windows version require the full .Net Framework 4.5.2 or higher. It may require some little fixes to work on Wine, but it should be easier to troubleshoot.

Partager ce message


Lien à poster
Partager sur d’autres sites

Uploaded a quick fix for November update.

 

This version remains the same since the build is broken and I can not rebuild it without rewriting everything.

If it fails, you may have to wait version 2.0, meanwhile you can try Wine for Mac and S4TI for Windows.

Partager ce message


Lien à poster
Partager sur d’autres sites

Sorry but the last 2 updates crash out the second you try to change households in the library. Even when you go back to the general tab before switching households. this is the last version that still works as long as you go back to general tab before changing households in the library.

 

Screen Shot 2017-11-08 at 4.00.52 PM.png

 

And sadly the last 2 updates to the windows version no longer start using virtualbox, the beta I got from you still works fine though.

Modifié par twmuse

Partager ce message


Lien à poster
Partager sur d’autres sites

@twmuse Sorry I can not patch this one, too much changes. :(

 

You'll have to wait for version 2.0 or try to run S4TI through Wine which allows Windows applications to run on Mac.

WineSkin, WineBottler or Play On Mac are modified versions of WineHQ designed to run better on Mac.

Partager ce message


Lien à poster
Partager sur d’autres sites
On 11/8/2017 at 5:54 PM, deevo said:

You'll have to wait for version 2.0 or try to run S4TI through Wine which allows Windows applications to run on Mac.

WineSkin, WineBottler or Play On Mac are modified versions of WineHQ designed to run better on Mac.

is there a tutorial on how to run the windows version through wine(bottler, skin, etc.)? i can't seem to figure it out because i need microsoft.net to be able to run the windows version, but i can't have it and s4ti setup running simultaneously in winebottler :'0 i'm not very experienced with wine and it's cousin programs, so i'm sorry if this is a silly question!!

Partager ce message


Lien à poster
Partager sur d’autres sites

@kuliritton Currently I don't think so. :ermm:

 

Wine is more common to Linux and Mac users, which I'm not.

 

Newer versions of Wine should simulate Windows 7 environment so you need to download Microsoft .Net Framework 4.5.2 or higher, the links are provided in both the release and beta page.

Some modified Wine comme pre installed with Mono which is not recommanded since WinForms is discontinued and unstable.

 

You should be able to find some tutorials on how to install .Net Framework on Wine.
Once installed you should not have any problems installing and running S4TI.

 

 

The Microsoft .NET 4.6.2 wrpr_v1.0 wrapper seems to come bundled with both WineSkin and .Net Framework preinstalled.

Citation

General Info:
This wrapper utilizes 3.7GB of disk space and is only compatible on Mac OSX 10.8 and above.

Wineskin wrapper utilizing WS9-64bitWineStaging2.2 with .Net 2.0 through to .Net4.6.2 plus the .Net verification tool. This wrapper should work with applications that require .Net 4.6.2 and lower. The full framework is not entirely implemented into Wine’s structure so expect some things to not work correctly.

Visual C++ 2005 to 2015, both x86 and x64 versions have been installed.

 

Installation:
Mount the .Net 4.6 disk image
Drag and drop the app to your preferred gaming folder
Install your app or game into the dot net wrapper
Configure the wrapper to your apps specifications
Enjoy!

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant




×